X

Код презентации скопируйте его

Ширина px

Вы можете изменить размер презентации, указав свою ширину плеера!

Система Logo Writer

Скачать эту презентацию

Презентация на тему Система Logo Writer

Скачать эту презентацию
Cлайд 1
Система Logo Writer Система Logo Writer
Cлайд 2
Программирование в среде ЛОГО Каждая программа для компьютера разрабатывается... Программирование в среде ЛОГО Каждая программа для компьютера разрабатывается на одном из языков – языков программирования. ЛОГО – образовано от древнегреческого «logos», что означает «мысль», «слово». Язык ЛОГО состоит из: алфавита (буквы – русские, цифры, символы) специально встроенные слова (команды- предложения на языке программирования для указания действия объекту)
Cлайд 3
Лист оглавления системыLogo Writer Logo_NEW ОГЛАВЛЕНИЕ С помощью клавиш выбер... Лист оглавления системыLogo Writer Logo_NEW ОГЛАВЛЕНИЕ С помощью клавиш выберите лист и нажмите клавишу Ввод Новый лист Формы
Cлайд 4
Интерфейс программы ЛОГО Рабочее поле Командный центр - для ввода команд на я... Интерфейс программы ЛОГО Рабочее поле Командный центр - для ввода команд на языке ЛОГО Исполнитель «Черепашка» На рабочем поле отображается исполнитель (черепашка) и результаты его действия Расстояние на рабочем поле измеряется в шагах Черепашки. Один шаг – один пиксель.
Cлайд 5
Правила записи команд На первом месте пишется название команды, а затем указы... Правила записи команд На первом месте пишется название команды, а затем указывается параметры Параметры команды – слово, число или выражение, уточняющее действие команды Вперед 50 Команда Параметр Название команды должно быть написано без ошибок – точно как в словаре. Между буквами в названии команды не должно быть пробелов. Если в команде есть параметр, то он отделяется от названия пробелом, если в одной строке записывается несколько команд, то они разделяются пробелами.
Cлайд 6
Ввод команды или последовательности команд должен заканчиваться нажатием клав... Ввод команды или последовательности команд должен заканчиваться нажатием клавиши «Enter». »ЧИСЛО» в командах вперёд, назад, налево, направо может быть как положительным, так и отрицательным!
Cлайд 7
Команды для графического исполнителя Название команды (краткая форма) Парамет... Команды для графического исполнителя Название команды (краткая форма) Параметр Действие исполнителя Вперед (вп) Число шагов Продвигается в направлении головы на указанное число шагов Назад (нд) Число шагов Продвигается в направлении против головы сотри нет Стирает рисунок, состояние Черепашки сохраняется домой нет Устанавливается в центр Рабочего стола, голова смотрит на север Направо (пр) Число градусов Поворачивается направо относительно направления, заданного головой Черепашки Налево (лв) Число градусов Поворачивается налево относительно направления, заданного головой Черепашки пп - Поднять перо по - Перо опустить
Cлайд 8
КОМАНДЫ ИСПОЛНИТЕЛЮ (черепашке) СЧ – «Спрячь Черепашку» ПЧ -«Покажи Черепашку... КОМАНДЫ ИСПОЛНИТЕЛЮ (черепашке) СЧ – «Спрячь Черепашку» ПЧ -«Покажи Черепашку» ИГ - «Исходная Графика»
Cлайд 9
СОКРАЩЁННЫЕ ФОРМЫ ЗАПИСИ СЛУЖЕБНЫХ СЛОВ вперёд вп налево лв назад нд направо пр СОКРАЩЁННЫЕ ФОРМЫ ЗАПИСИ СЛУЖЕБНЫХ СЛОВ вперёд вп налево лв назад нд направо пр
Cлайд 10
ПОВОРОТЫ ЧЕРЕПАШКИ НАПРАВО 90 НАЛЕВО 90 направо -45 НАПРАВО-135 ПОВОРОТЫ ЧЕРЕПАШКИ НАПРАВО 90 НАЛЕВО 90 направо -45 НАПРАВО-135
Cлайд 11
Команды НАЗАД 90 и ВПЕРЁД 90 Команды НАЗАД 90 и ВПЕРЁД 90
Cлайд 12
Задача. Укажите последовательность команд для вычерчивания квадрата со сторон... Задача. Укажите последовательность команд для вычерчивания квадрата со стороной 40. Решение. Иг Вперед 40 направо 90 Вперед 40 направо 90 Вперед 40 направо 90 Вперед 40 направо 90 сч
Cлайд 13
Задание. Укажите последовательность команд для вычерчивания фигуры «одним рос... Задание. Укажите последовательность команд для вычерчивания фигуры «одним росчерком пера»:
Cлайд 14
назад 40 направо 90 вперед 20 налево 90 вперед 40 назад 40 налево 90 вперед 4... назад 40 направо 90 вперед 20 налево 90 вперед 40 назад 40 налево 90 вперед 40 направо 90 вперед 40 назад 40 направо 90 вперед 20 направо 90 вперед 120
Cлайд 15
Cлайд 16
60 60 60 60 60 40 80 40 40 40 40 40 40 40 40 40 40 60 60 60 60 60 40 80 40 40 40 40 40 40 40 40 40 40
Cлайд 17
Организация циклов в среде LogoWriter Организация циклов в среде LogoWriter
Cлайд 18
Задача. Укажите последовательность команд для вычерчивания квадрата со сторон... Задача. Укажите последовательность команд для вычерчивания квадрата со стороной 40. Решение. Иг Вперед 40 пр 90 Вперед 40 пр 90 Вперед 40 пр 90 Вперед 40 пр 90 сч
Cлайд 19
повтори [список команд] Иг повтори 4 [Вперед 40 пр 90] Задача: укажите послед... повтори [список команд] Иг повтори 4 [Вперед 40 пр 90] Задача: укажите последовательность команд , вычерчивающих равносторонний треугольник. Команда повтори
Cлайд 20
Иг повтори360 [Вперед 1 пр 1] сч Вычерчивание окружности. Иг повтори360 [Вперед 1 пр 1] сч Вычерчивание окружности.
Cлайд 21
Иг повтори 4 [повтори 180 [Вп 1 пр 2] пр 90] сч Иг повтори 4 [повтори 180 [Вп 1 пр 2] пр 90] сч
Cлайд 22
пусть “S 0 пусть “N 1 повтори 12 [вп :N пусть “S :S +:N пусть “N :N + 2] ? пусть “S 0 пусть “N 1 повтори 12 [вп :N пусть “S :S +:N пусть “N :N + 2] ?
Cлайд 23
Cлайд 24
Понятие процедуры. Процедура – подпрограмма( программа, которую вызывают друг... Понятие процедуры. Процедура – подпрограмма( программа, которую вызывают другие программы). Пример: это квадрат повтори 4[вперед 40 направо 90] конец Процедура состоит: 1)из заголовка( служебное слово это и имя процедуры). 2)последовательности команд 3)служебного слова конец.
Cлайд 25
Правила записи процедуры. Заголовок и служебное слово конец должны размещатьс... Правила записи процедуры. Заголовок и служебное слово конец должны размещаться на отдельных строках. Для записи процедуры предназначена изнаночная сторона листа. Переход с одной стороны листа на другую осуществляется либо по команде переверни , либо по нажатию клавиш+
Cлайд 26
Вызов процедуры. Для вызова процедуры предназначена лицевая сторона листа: на... Вызов процедуры. Для вызова процедуры предназначена лицевая сторона листа: набрать в поле команд имя процедуры. Задание: составьте процедуру вычерчивания прямоугольника со сторонами 50 и 40; составьте процедуру вычерчивания треугольника со стороной 40; К процедуре можно обращаться из последующих процедур. составьте процедуру , рисующую домик, используя две предыдущие процедуры.
Cлайд 27
Домик Домик
Cлайд 28
Вложенные процедуры. это прямоугольник повтори 2[вп 50 пр 90 вп 40 пр 90] кон... Вложенные процедуры. это прямоугольник повтори 2[вп 50 пр 90 вп 40 пр 90] конец это треугольник вп 40 лв 120 вп 40 лв 120 вп 40 конец Это домик прямоугольник вп 51 пр 90 треугольник конец домик- головная процедура; треугольник, прямоугольник - вложенные процедуры.
Cлайд 29
Написать процедуру составления узора из квадрата со стороной 20. это квадрат ... Написать процедуру составления узора из квадрата со стороной 20. это квадрат повтори 4[вп 20 пр 90] конец
Cлайд 30
узор это узор пп лв 90 вп 20 пр90 по (переместили черепашку влево на один ква... узор это узор пп лв 90 вп 20 пр90 по (переместили черепашку влево на один квадрат) повтори 3[квадрат пп пр 90 вп 20 лв 90 вп 10 пр 45 по квадрат пп лв 90 нд 20 пр 90 вп 20 лв 45 нд 10 по] сч конец
Cлайд 31
задание: уменьшить сторону квадрата до 10 пикселей, количество фрагментов узо... задание: уменьшить сторону квадрата до 10 пикселей, количество фрагментов узора увеличить вдвое. Задание 2: нарисовать пятиконечную звезду (угол звезды 360)
Cлайд 32
назначение функциональных клавиш при наборе процедур удаление символов от кур... назначение функциональных клавиш при наборе процедур удаление символов от курсора до конца строки переключение алфавита включение режима выделения текста запись выделенного фрагмента в буфер( текст с экрана исчезает) (вырезать) то же(текст не исчезает) (копировать) вывод на экран с позиции курсора фрагмента из буфера
Cлайд 33
Скачать эту презентацию
Наверх